#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(http[s]?:\/\/)?www\.(?=.+)"
Local $sString = "1)lorum ipsum www.goal.com" & @CRLF & _
"2)lorum ipsum http://www.goal.com" & @CRLF & _
"3)lorum ipsum https://www.goal.com" & @CRLF & _
"4)lorum ipsum https://www.goal.com/1234" & @CRLF & _
"5)lorum ipsum www."
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)