re = /(http[s]?:\/\/)?www\.(?=.+)/m
str = '1)lorum ipsum www.goal.com
2)lorum ipsum http://www.goal.com
3)lorum ipsum https://www.goal.com
4)lorum ipsum https://www.goal.com/1234
5)lorum ipsum www.'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result