# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/[ \t]*\|.*//gm;t' <<< "DATA102:991n| DATA | Data222
DATA10:22 | DATA | Data222
DATA102:991 | DATA | Data222
DATA10:22 | DATA | Data222
DATA102:991 | DATA | Data222
DATA10:22 | DATA | Data222"