#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)[ \t]*\|.*"
Local $sString = "DATA102:991n| DATA | Data222" & @CRLF & _
"DATA10:22 | DATA | Data222" & @CRLF & _
"DATA102:991 | DATA | Data222" & @CRLF & _
"DATA10:22 | DATA | Data222" & @CRLF & _
"DATA102:991 | DATA | Data222" & @CRLF & _
"DATA10:22 | DATA | Data222"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)