import re
regex = re.compile(r"[ \t]*\|.*", flags=re.MULTILINE)
test_str = ("DATA102:991n| DATA | Data222\n"
"DATA10:22 | DATA | Data222\n"
"DATA102:991 | DATA | Data222\n"
"DATA10:22 | DATA | Data222\n"
"DATA102:991 | DATA | Data222\n"
"DATA10:22 | DATA | Data222")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)