re = /[ \t]*\|.*/m
str = 'DATA102:991n| DATA | Data222
DATA10:22 | DATA | Data222
DATA102:991 | DATA | Data222
DATA10:22 | DATA | Data222
DATA102:991 | DATA | Data222
DATA10:22 | DATA | Data222'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result