$re = '/[ \t]*\|.*/m';
$str = 'DATA102:991n| DATA | Data222
DATA10:22 | DATA | Data222
DATA102:991 | DATA | Data222
DATA10:22 | DATA | Data222
DATA102:991 | DATA | Data222
DATA10:22 | DATA | Data222';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;