const regex = /[ \t]*\|.*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[ \\t]*\\|.*', 'gm')
const str = `DATA102:991n| DATA | Data222
DATA10:22 | DATA | Data222
DATA102:991 | DATA | Data222
DATA10:22 | DATA | Data222
DATA102:991 | DATA | Data222
DATA10:22 | DATA | Data222`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);