# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/x(.{5,})/\1/gm;t' <<< "x1234
x12345
123456"