package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)x(.{5,})`)
var str = `x1234
x12345
123456`
var substitution = "\1"
fmt.Println(re.ReplaceAllString(str, substitution))
}