using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"x(.{5,})";
string substitution = @"\1";
string input = @"x1234
x12345
123456";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}