const regex = new RegExp('x(.{5,})', 'gm')
const str = `x1234
x12345
123456`;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);