$re = '/x(.{5,})/m';
$str = 'x1234
x12345
123456';
$subst = "\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;