use strict;
my $str = 'x1234
x12345
123456';
my $regex = qr/x(.{5,})/mp;
my $subst = '\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";