# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/.*(?|(dog).*(cat)|(cat).*(dog)).*/\1 \2/g;t' <<< "aasdfadsf cat asdfadsf dog
asfdadsfads dog asdfasdfadsf cat"