$re = '/.*(?|(dog).*(cat)|(cat).*(dog)).*/';
$str = 'aasdfadsf cat asdfadsf dog
asfdadsfads dog asdfasdfadsf cat';
$subst = "\1 \2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;