#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = ".*(?|(dog).*(cat)|(cat).*(dog)).*"
Local $sString = "aasdfadsf cat asdfadsf dog" & @CRLF & _
"asfdadsfads dog asdfasdfadsf cat"
Local $sSubst = "\1 \2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)