using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*(?|(dog).*(cat)|(cat).*(dog)).*";
string substitution = @"\1 \2";
string input = @"aasdfadsf cat asdfadsf dog
asfdadsfads dog asdfasdfadsf cat";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}