use strict;
my $str = 'aasdfadsf cat asdfadsf dog
asfdadsfads dog asdfasdfadsf cat';
my $regex = qr/.*(?|(dog).*(cat)|(cat).*(dog)).*/p;
my $subst = '\\1 \\2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";