#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)((^|\S+)Nennbetrag(\S+|$))|((^|\S+)Nennbetrag)|(Nennbetrag(\S+|$))"
Local $sString = "Nennbetrag" & @CRLF & _
"Nennbetrag " & @CRLF & _
" Nennbetrag" & @CRLF & _
" Nennbetrag " & @CRLF & _
"Nennbetrag " & @CRLF & _
" Nennbetrag" & @CRLF & _
" Nennbetrag " & @CRLF & _
"Nennbetragaaaa" & @CRLF & _
"aaaaNennbetrag" & @CRLF & _
"aaaaNennbetragaaaa" & @CRLF & _
"Nennbetrag a " & @CRLF & _
" a Nennbetrag" & @CRLF & _
" a Nennbetrag a " & @CRLF & _
"Nennbetra" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")