re = /((^|\S+)Nennbetrag(\S+|$))|((^|\S+)Nennbetrag)|(Nennbetrag(\S+|$))/m
str = 'Nennbetrag
Nennbetrag
Nennbetrag
Nennbetrag
Nennbetrag
Nennbetrag
Nennbetrag
Nennbetragaaaa
aaaaNennbetrag
aaaaNennbetragaaaa
Nennbetrag a
a Nennbetrag
a Nennbetrag a
Nennbetra
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end