const regex = /((^|\S+)Nennbetrag(\S+|$))|((^|\S+)Nennbetrag)|(Nennbetrag(\S+|$))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((^|\\S+)Nennbetrag(\\S+|$))|((^|\\S+)Nennbetrag)|(Nennbetrag(\\S+|$))', 'gm')
const str = `Nennbetrag
Nennbetrag
Nennbetrag
Nennbetrag
Nennbetrag
Nennbetrag
Nennbetrag
Nennbetragaaaa
aaaaNennbetrag
aaaaNennbetragaaaa
Nennbetrag a
a Nennbetrag
a Nennbetrag a
Nennbetra
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}