package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)((^|\S+)Nennbetrag(\S+|$))|((^|\S+)Nennbetrag)|(Nennbetrag(\S+|$))`)
var str = `Nennbetrag
Nennbetrag
Nennbetrag
Nennbetrag
Nennbetrag
Nennbetrag
Nennbetrag
Nennbetragaaaa
aaaaNennbetrag
aaaaNennbetragaaaa
Nennbetrag a
a Nennbetrag
a Nennbetrag a
Nennbetra
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}