#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:t|tg|telegram)(?:\.|:/)(?:me|dog|)/(?:\+|joinchat/|join\?invite=)?([\w-]+)"
Local $sString = "t.me/+TuxVLdSmj1RiMTEy" & @CRLF & _
"t.me/joinchat/TuxVLdSmj1RiMTEy (legacy)" & @CRLF & _
"tg://join?invite=TuxVLdSmj1RiMTEy" & @CRLF & _
"telegram.me/+TuxVLdSmj1RiMTEy" & @CRLF & _
"https://t.me/test_bot"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")