import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:t|tg|telegram)(?:\\.|:/)(?:me|dog|)/(?:\\+|joinchat/|join\\?invite=)?([\\w-]+)";
final String string = "t.me/+TuxVLdSmj1RiMTEy\n"
+ "t.me/joinchat/TuxVLdSmj1RiMTEy (legacy)\n"
+ "tg://join?invite=TuxVLdSmj1RiMTEy\n"
+ "telegram.me/+TuxVLdSmj1RiMTEy\n"
+ "https://t.me/test_bot";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}