$re = '@(?:t|tg|telegram)(?:\.|:/)(?:me|dog|)/(?:\+|joinchat/|join\?invite=)?([\w-]+)@m';
$str = 't.me/+TuxVLdSmj1RiMTEy
t.me/joinchat/TuxVLdSmj1RiMTEy (legacy)
tg://join?invite=TuxVLdSmj1RiMTEy
telegram.me/+TuxVLdSmj1RiMTEy
https://t.me/test_bot';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);