re = /(?:t|tg|telegram)(?:\.|:\/)(?:me|dog|)\/(?:\+|joinchat\/|join\?invite=)?([\w-]+)/m
str = 't.me/+TuxVLdSmj1RiMTEy
t.me/joinchat/TuxVLdSmj1RiMTEy (legacy)
tg://join?invite=TuxVLdSmj1RiMTEy
telegram.me/+TuxVLdSmj1RiMTEy
https://t.me/test_bot'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end