package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:t|tg|telegram)(?:\.|:/)(?:me|dog|)/(?:\+|joinchat/|join\?invite=)?([\w-]+)`)
var str = `t.me/+TuxVLdSmj1RiMTEy
t.me/joinchat/TuxVLdSmj1RiMTEy (legacy)
tg://join?invite=TuxVLdSmj1RiMTEy
telegram.me/+TuxVLdSmj1RiMTEy
https://t.me/test_bot`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}