using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[^\n\r\t:]+(?=:(?:.*\R\t)*status:\h+active)";
string input = @"ABC 12:
text....
text.......
status: active
XYZ 34:
word word word
status: active
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}