const regex = /^[^\n\r\t:]+(?=:(?:.*\R\t)*status:\h+active)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[^\\n\\r\\t:]+(?=:(?:.*\\R\\t)*status:\\h+active)', 'gm')
const str = `ABC 12:
text....
text.......
status: active
XYZ 34:
word word word
status: active
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}