re = /^[^\n\r\t:]+(?=:(?:.*\R\t)*status:\h+active)/m
str = 'ABC 12:
text....
text.......
status: active
XYZ 34:
word word word
status: active
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end