$re = '/^[^\n\r\t:]+(?=:(?:.*\R\t)*status:\h+active)/m';
$str = 'ABC 12:
text....
text.......
status: active
XYZ 34:
word word word
status: active
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);