#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^qa\d+$"
Local $sString = "qa1" & @CRLF & _
"qa2" & @CRLF & _
"qa3" & @CRLF & _
"qa4" & @CRLF & _
"qa5" & @CRLF & _
"qa6" & @CRLF & _
"qa7" & @CRLF & _
"qa8" & @CRLF & _
"qa9" & @CRLF & _
"qa10" & @CRLF & _
"qa11" & @CRLF & _
"qa12" & @CRLF & _
"qa13" & @CRLF & _
"qa14" & @CRLF & _
"qa15" & @CRLF & _
"qa16" & @CRLF & _
"qa17" & @CRLF & _
"qa18" & @CRLF & _
"qa19" & @CRLF & _
"qa10_products" & @CRLF & _
"qa11_addresses" & @CRLF & _
"qa11_related_products" & @CRLF & _
"qa12_addresses"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")