// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^qa\d+$").unwrap();
let string = "qa1
qa2
qa3
qa4
qa5
qa6
qa7
qa8
qa9
qa10
qa11
qa12
qa13
qa14
qa15
qa16
qa17
qa18
qa19
qa10_products
qa11_addresses
qa11_related_products
qa12_addresses";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}