import re
regex = re.compile(r"^qa\d+$", flags=re.MULTILINE)
test_str = ("qa1\n"
"qa2\n"
"qa3\n"
"qa4\n"
"qa5\n"
"qa6\n"
"qa7\n"
"qa8\n"
"qa9\n"
"qa10\n"
"qa11\n"
"qa12\n"
"qa13\n"
"qa14\n"
"qa15\n"
"qa16\n"
"qa17\n"
"qa18\n"
"qa19\n"
"qa10_products\n"
"qa11_addresses\n"
"qa11_related_products\n"
"qa12_addresses")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")