const regex = new RegExp('^qa\\d+$', 'gm')
const str = `qa1
qa2
qa3
qa4
qa5
qa6
qa7
qa8
qa9
qa10
qa11
qa12
qa13
qa14
qa15
qa16
qa17
qa18
qa19
qa10_products
qa11_addresses
qa11_related_products
qa12_addresses`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}