using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^qa\d+$";
string input = @"qa1
qa2
qa3
qa4
qa5
qa6
qa7
qa8
qa9
qa10
qa11
qa12
qa13
qa14
qa15
qa16
qa17
qa18
qa19
qa10_products
qa11_addresses
qa11_related_products
qa12_addresses";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}