package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^qa\d+$`)
var str = `qa1
qa2
qa3
qa4
qa5
qa6
qa7
qa8
qa9
qa10
qa11
qa12
qa13
qa14
qa15
qa16
qa17
qa18
qa19
qa10_products
qa11_addresses
qa11_related_products
qa12_addresses`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}