# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\b|(?<=\W)(?=\W)/\n/g;t' <<< "1+2+3
2/1*100
1+2+3/3*100
(1*2)/(3*4)*100"