import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b|(?<=\\W)(?=\\W)";
final String string = "1+2+3\n"
+ "2/1*100\n"
+ "1+2+3/3*100\n"
+ "(1*2)/(3*4)*100";
final String subst = "\\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}