import re
regex = re.compile(r"\b|(?<=\W)(?=\W)")
test_str = ("1+2+3\n"
"2/1*100\n"
"1+2+3/3*100\n"
"(1*2)/(3*4)*100")
subst = "\\n"
result = regex.sub(subst, test_str)
if result:
print(result)