$re = '/\b|(?<=\W)(?=\W)/';
$str = '1+2+3
2/1*100
1+2+3/3*100
(1*2)/(3*4)*100';
$subst = "\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;