#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[a-zA-Z][a-zA-Z0-9_]{3,24}$(?<!_)"
Local $sString = "The username is between 4 and 25 characters." & @CRLF & _
"It must start with a letter." & @CRLF & _
"It can only contain letters, numbers, and the underscore character." & @CRLF & _
"It cannot end with an underscore character."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")