import re
regex = re.compile(r"^[a-zA-Z][a-zA-Z0-9_]{3,24}$(?<!_)", flags=re.MULTILINE)
test_str = ("The username is between 4 and 25 characters.\n"
"It must start with a letter.\n"
"It can only contain letters, numbers, and the underscore character.\n"
"It cannot end with an underscore character.")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")