import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[a-zA-Z][a-zA-Z0-9_]{3,24}$(?<!_)";
final String string = "The username is between 4 and 25 characters.\n"
+ "It must start with a letter.\n"
+ "It can only contain letters, numbers, and the underscore character.\n"
+ "It cannot end with an underscore character.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}