const regex = new RegExp('^[a-zA-Z][a-zA-Z0-9_]{3,24}$(?<!_)', 'gm')
const str = `The username is between 4 and 25 characters.
It must start with a letter.
It can only contain letters, numbers, and the underscore character.
It cannot end with an underscore character.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}