use strict;
my $str = 'The username is between 4 and 25 characters.
It must start with a letter.
It can only contain letters, numbers, and the underscore character.
It cannot end with an underscore character.';
my $regex = qr/^[a-zA-Z][a-zA-Z0-9_]{3,24}$(?<!_)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}