re = /^[a-zA-Z][a-zA-Z0-9_]{3,24}$(?<!_)/m
str = 'The username is between 4 and 25 characters.
It must start with a letter.
It can only contain letters, numbers, and the underscore character.
It cannot end with an underscore character.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end