#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)(<item>[^<]*?<title>(?<title>[^<]*?)<\/title>([^<]|<(?!description))*<description>(?<desc>[^<]*?keyword[^<]*?)<\/description>[^<]*?<\/item>)"
Local $sString = "<item>" & @CRLF & _
"<title>bla</title>" & @CRLF & _
"..." & @CRLF & _
"<description>bla</description>" & @CRLF & _
"</item>" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"<item>" & @CRLF & _
"<title>bla2</title>" & @CRLF & _
"<summary>bla2</summary>" & @CRLF & _
"<summary>bla2</summary>" & @CRLF & _
"<summary>bla2</summary>" & @CRLF & _
"<description>bla2, keyword here are blablabla</description>" & @CRLF & _
"</item>" & @CRLF & _
"" & @CRLF & _
"<item>" & @CRLF & _
"<title>bla2</title>" & @CRLF & _
"...." & @CRLF & _
"<description>no kword here</description>" & @CRLF & _
"</item>" & @CRLF & _
"" & @CRLF & _
"blablabla" & @CRLF & _
"" & @CRLF & _
"<item>" & @CRLF & _
"<title>bla</title>" & @CRLF & _
"..." & @CRLF & _
"<description>bla</description>" & @CRLF & _
"</item>" & @CRLF & _
"" & @CRLF & _
"<item>" & @CRLF & _
"<title>bla2</title>" & @CRLF & _
"<summary>bla2</summary>" & @CRLF & _
"<description>bla2, keyword here are blablabla</description>" & @CRLF & _
"</item>" & @CRLF & _
"" & @CRLF & _
"<item>" & @CRLF & _
"<title>bla2</title>" & @CRLF & _
"<summary>bla2</summary>" & @CRLF & _
"<description>bla2, keyword here are blablabla</description>" & @CRLF & _
"</item>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")