use strict;
my $str = '<item>
<title>bla</title>
...
<description>bla</description>
</item>
<item>
<title>bla2</title>
<summary>bla2</summary>
<summary>bla2</summary>
<summary>bla2</summary>
<description>bla2, keyword here are blablabla</description>
</item>
<item>
<title>bla2</title>
....
<description>no kword here</description>
</item>
blablabla
<item>
<title>bla</title>
...
<description>bla</description>
</item>
<item>
<title>bla2</title>
<summary>bla2</summary>
<description>bla2, keyword here are blablabla</description>
</item>
<item>
<title>bla2</title>
<summary>bla2</summary>
<description>bla2, keyword here are blablabla</description>
</item>';
my $regex = qr/(<item>[^<]*?<title>(?<title>[^<]*?)<\/title>([^<]|<(?!description))*<description>(?<desc>[^<]*?keyword[^<]*?)<\/description>[^<]*?<\/item>)/sp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}